[Disruptions] Exchange mail
Incident Report for CloudNordic
Resolved
The last few problems of the incident was solved by rebooting our redundant setup because it was out of sync.
Everything is operational again.
Posted Apr 20, 2020 - 11:46 CEST
Monitoring
Services are operational again.
A select few will be experiencing issues with Outlook clients forcing to re-type passwords after restarting Outlook. We are working on a fix for that.

We will be performing a restart of one of the primary exchange servers which will result in a few minutes of additional down time.
Posted Apr 20, 2020 - 11:37 CEST
Investigating
We're experiencing some disruptions with the Exchange mail system

Start: 20-04-2020 11:00 CET
End: 20-04-2020 12:00 CET (Expected)
Posted Apr 20, 2020 - 11:10 CEST
This incident affected: CloudNordic services (Hosted Exchange).