[Disruptions] Exchange mail
Incident Report for CloudNordic
Resolved
13:25: Everything is running again
Posted Oct 26, 2018 - 13:29 CEST
Investigating
We're experiencing some disruptions with the Exchange mail system

Start: 26-10-2018 13:00 CET
End: 26-10-2018 14:00 CET (Expected)

Best Regards,
Best Regards, CloudNordic Operational and Helpdesk team
Posted Oct 26, 2018 - 13:14 CEST
This incident affected: CloudNordic services (Hosted Exchange).